Jira のトラブルシューティング (2)
Jira 管理画面の開き方
トラブルの対応方法を説明する前に、Jira の管理画面を開く方法を確認しておきます。
全体の管理画面
Jira に管理者ユーザーでログインします。画面の右上に歯車マーク
プロジェクトの管理画面
Jira に管理者ユーザーでログインし、管理したいプロジェクトを開きます。画面上部のメニューから「プロジェクト」をクリックし、管理したいプロジェクトをクリックします。
プロジェクトの詳細画面が表示されます。管理者ユーザーでログインしていると、左下に「プロジェクト設定」というリンクが表示されています。ここをクリックするとプロジェクトの管理画面が開きます。
次のようなプロジェクトの管理画面が表示されます。
アバターや画像が正しく表示されない
現象
ダッシュボード画面のアクティビティストリームなどに、アバターや画像が表示されなくなっていることがあります。また、一部のリンクもリンク切れになっています。
リンクをクリックすると、以下のようにリンク切れのページが表示されます。
(ブラウザとしてGoogle Chromeを使用した場合の例です)
原因
原因を判断するためのポイントは、リンク切れページの表示内容にあります。「~では 127.0.0.1:8080 に接続できませんでした
」と表示されています。このメッセージ内の 127.0.0.1:8080
は、通常はJIRAサーバを指すアドレス( jira.xxxxx.yy.zz
など)になりますが、ローカルホスト(自分自身)を指す特別なIPアドレス(127.0.0.1
)になっています。
このため、クライアントPCなどJIRAサーバーの外側にあるマシンからはリソースを参照できず、画像が表示されなかったり、リンクが切れているなどの現象が発生します。
ご参考
「127.0.0.1
」ではなく「localhost
」が使用されていることもあります。
対策
セットアップウィザードを実行したときにIPアドレス「127.0.0.1
」(または「localhost
」)を使用していたか、JIRAの設定を変更したときにベースURLの設定を誤って修正したことが原因と思われます。
以下の手順でベースURLの設定を確認してください。
- 584814698。
- 「システム」の「一般設定」を開く。
- 「設定」欄の「ベースURL」の内容を確認する
↑上の管理画面で「システム」の「一般設定」をクリックし、↓下の設定画面を開きます。
ベースURLに表示されている内容を確認してください。↑この画面の例では、自分自身を指す「127.0.0.1
」というIPアドレスが設定されています。正しくは、JIRAサーバー外のコンピューターからアクセスできるURLを設定する必要があります。
どのようなURLを設定すればいいのかわからないときは、ネットワーク管理者にご相談ください。
設定を編集するには、画面の一番下にある「設定を編集」ボタンをクリックします。
↓下の画面のように設定値を編集できるようになるので、ベースURLの内容を正しいURLに変更してください。
変更できたら、画面の一番下にある「更新」ボタンをクリックして編集を確定します。
ベースURLを正しく設定できると、次の画面イメージのようにアバターなどの画像が表示され、リンク切れも発生しなくなります。
JIRAから通知メールが送信されない
JIRAには、新しい課題が報告されたり、既存の課題が変更されたりすると、関係するユーザーにメール通知する機能があります。
ただし、各ユーザーのメールアドレスを設定するだけでは使用できません。JIRAに利用できるメールサーバーの情報を設定し、プロジェクト単位にどのイベントに対してメールを送信するか指定する(通知スキームを指定する)必要があります。
使用するメールサーバーを設定する
584814698を開きます。右下の方にある「メール...
」の「送信メール
」をクリックして、電子メールサーバーの設定画面を開きます。
初めて設定画面を開いたときは、設定済みのサーバーは無いというメッセージが表示されています。「新規 SMTP メール サーバーの設定
」ボタンをクリックします。
メールサーバーの設定画面が開きます。JIRAで使用したいメールサーバーの情報などを設定します。
入力項目のうち、最初の4項目はJIRAに固有の設定です。
内容 | 設定例 | |
名前 | JIRAの中でこのメールサーバーを識別するための名前です。任意の名前を指定してください。 | 通知メール送信用サーバー |
---|---|---|
説明 | このメールサーバーに関する説明です。 | JIRAからの通知メール送信に使用します。 |
送信元アドレス | JIRAから送信するメールの送信元として使用するアドレスです。 | jira@dummy.com |
メール プレフィックス | JIRAから送信するメールの件名の先頭に追加する識別子です。JIRAからのメールであることを見分けられるものにしてください。 | [JIRA] |
その他のメールサーバーの詳細設定は、ネットワーク管理者とご相談のうえ指定を行なってください。
ご参考
Atlassianのドキュメント「Configuring JIRA's SMTP Mail Server to Send Notifications」(英語)も参照してください。
指定できたら「Test Connection
」ボタンをクリックして接続テストを実施し、設定を確認します。
「接続が成功しました
」というメッセージが表示されたら、「追加
」ボタンをクリックしてサーバー設定を追加します。
「SMTPメールサーバー
」の画面に戻り、いま追加したメールサーバー設定が表示されていることを確認してください。
プロジェクトに通知スキームを指定する
続いて、通知スキームの設定を行います。通知スキームとは、プロジェクト単位に設定し、どのイベントに対して通知を行うのかをまとめて定義するものです。
通知スキームについての詳細は、Atlassianのドキュメント「Configuring JIRA application emails」(英語)もご覧ください。
ここでは、JIRAにあらかじめ用意されている「既定の通知スキーム」をプロジェクトに指定する手順をご紹介します。
プロジェクトに通知スキームを設定するには、まず584814698を開きます。
画面右下の方に「通知
」欄があり、スキームが「なし
」になっています。「なし
」がリンクになっているので、ここをクリックして編集画面を開きます。
通知スキームが設定されていないので「このプロジェクトに通知はありません。
」というメッセージが表示されています。
右上の歯車アイコンをクリックして表示されるメニューから「スキームの選択
」をクリックします。
プロジェクトで使用する通知スキームを選択する画面が表示jされるので、ここでは「既定の通知スキーム
」をドロップダウンリストから選択し、「関連付け
」ボタンをクリックします。
プロジェクトに「既定の通知スキーム
」が関連付けられ、イベントと通知先のリストが表示されます。
以上で設定は終了です。プロジェクトの管理画面に戻ると、設定した通知スキームの名前が表示されています。
テスト用の課題を操作するなどして、メールによる通知が行われることを確認してください。
ご参考
「既定の通知スキーム
」では、すべてのシステムイベントに対して通知メールが送信されます。送信される通知メールの数が多いときは、独自の通知スキームを設定してください。
通知スキームは、JIRAの管理画面の左下の方に表示されている「通知スキーム
」から設定できます。最初は「既定の通知スキーム
」をコピーし変更する方法をおススメします。
プロファイル設定の確認
584814698と584814698を行なっても通知メールが送信されないときは、ユーザープロファイルでメールが送信されないように設定されている可能性があります。
画面右上のユーザー名のさらに右側にある「▼
」をクリックしてドロップダウンメニューを表示し、「プロファイル
」をクリックしてください。 ユーザープロファイル画面の「要約
」タブが表示されます。「ユーザー設定
」にある「自分の変更
」が「自分に通知しない
」になっていると、自分の操作結果がメールで通知されません。
「ユーザー設定
」の右側にある鉛筆アイコンをクリックすると設定画面がポップアップ表示されるので、通知されるように設定を変更してみてください。
グラフなどの動的に生成される画像の日本語が正しく表示されない
ダッシュボードに表示した円グラフガジェットなど、動的に画像を生成、表示するときに、日本語文字が「□」(四角)で表示されることがあります。この現象は、Linux環境下でのみ発生します。
確認手順
お使いのJIRAのバージョンや環境によっては、すでに対策が施されていて現象が発生しなくなっているかもしれません。次の手順で表示内容をご確認ください。
任意のユーザーでログインした状態で、画面左上の「JIRA
」ロゴをクリックし、ダッシュボード画面を表示します。メニューのいちばん左にある「ダッシュボード
」をクリックし、「ダッシュボードの管理
」を選択します。
「ダッシュボードの管理
」画面が表示されたら、右上の「ダッシュボードを新規作成
」をクリックします。
「ダッシュボードの新規作成
」画面が表示されるので、「名前
」に適当な名前を入力して「追加
」ボタンをクリックします。ここでは、名前に「グラフのテスト用」と入力しました。
ダッシュボードの管理画面に戻り、「お気に入りのダッシュボード
」が表示されます。この中に先ほど追加したダッシュボードがあるので、名前のリンクをクリックします。
空白のダッシュボード画面が表示されます。右上の方にある「ガジェットの追加
」をクリックします。
「ガジェットディレクトリ
」の画面が表示されます。リストの中から「円グラフ
」を探し、「今すぐ追加
」ボタンをクリックしてください。そのあと右下の「完了
」ボタンをクリックしてこの画面を閉じます。
ダッシュボードに戻ると、円グラフの内容を設定する画面が表示されています。「プロジェクトまたは保存済みフィルター
」と「統計の種類
」の内容を適当に設定して「保存
」ボタンをクリックします。表示の確認用にグラフを作成するだけなので、お好みで設定していただいて構いません。
ダッシュボードに円グラフが表示されます。下のグラフの赤で囲んだ部分に日本語が表示されていれば問題ありません。対策は不要です。
こちら↓の画面のように、日本語の代わりに□
が表示されているときは対策が必要です。
この現象は、画像の生成時に日本語を含むTrueTypeフォントを使用していないため、日本語の文字を描画できないことが原因です。JIRAの問題ではなく、JIRAの実行に使用しているJava(JRE、JDK)やオペレーティングシステム(OS)に依存する問題です。
対策手順
手順1 日本語サポートの確認
ご利用のOSに日本語を利用するための機能がインストールされているか確認します。「yum grouplist
」コマンドを実行して、yumコマンドで利用できるグループのリストを表示します。「Installed Language Groups:
」リストに「Japanese Support [ja]
」または「日本語のサポート [ja]
」が表示されていることを確認します。英語環境と日本語環境で表示される内容が少し異なるのでご注意ください。
# yum grouplist
Loaded plugins: fastestmirror, security
Setting up Group Process
Loading mirror speeds from cached hostfile
* base: ftp.riken.jp
* extras: ftp.riken.jp
* updates: ftp.riken.jp
Installed Groups:
Additional Development
(……省略……)
Server Platform
Installed Language Groups:
Arabic Support [ar]
(……省略……)
Inuktitut Support [iu]
Japanese Support [ja]
Korean Support [ko]
Lao Support [lo]
Tajik Support [tg]
Available Groups:
Backup Client
(……省略……)
iSCSI Storage Client
Available Language Groups:
Afrikaans Support [af]
(……省略……)
Zulu Support [zu]
Done
# yum grouplist
Loaded plugins: fastestmirror, security
Setting up Group Process
Loading mirror speeds from cached hostfile
* base: ftp.riken.jp
* extras: ftp.riken.jp
* updates: ftp.riken.jp
Installed Groups:
NFS ファイルサーバー
(……省略……)
電子メールサーバー
Installed Language Groups:
アラビア語のサポート [ar]
(……省略……)
ラオ語のサポート [lo]
日本語のサポート [ja]
韓国語のサポート [ko]
Available Groups:
CIFS ファイルサーバー
(……省略……)