解決状況フィールドのオプションに「完了」が二つ表示されてしまう
質問
解決状況フィールドのオプションに「完了」が二つ表示されてしまいます。
こちらの修正方法を教えてください。
回答
原因
こちらは、Jira がシステムの既定言語に対応した解決状況を自動で作成することによって発生します。
Jira にはデフォルトで用意されている解決状況「Done」がありますが、この値が翻訳されて日本語では「完了」と表示されます(混乱を避けるため、以下「Done」と記述します)。
また、下記のチケットに記載されている通り、システムの既定言語を変更してプロジェクトを作成すると、その言語に対応する解決状況が自動で作成されてしまいます。
- JRASERVER-43539(Server/Data Center 版)
- JRACLOUD-43539(Cloud 版)
「Done」はデフォルトとして Jira に存在している解決状況で、「完了」は Jira の既定言語が日本語の状態でプロジェクトを作成したときに自動で作成される解決状況となります。
これらの解決状況を削除しても、Jira の既定言語が日本語に設定されていればプロジェクトを作成する度に「完了」の解決状況は作成され、言語に関わらず「Done」もプロジェクト作成時に追加されてしまいます。
回避策
1. Jira の既定言語を英語にする
原因について説明しました通り Jira の既定言語を変更することで発生してしまうため、既定言語を英語にしていただくことで、新しく「完了」の解決状況が作成されるのを回避することができます。
プロジェクト作成時に併せて作成されるワークフローや課題タイプ画面スキームなども英語となってしまいますのでご注意ください。
2. 重複している解決状況に「翻訳」を設定する
既定言語の選択 > 既知の問題 のページにも記載されている通り、解決状況に翻訳を設定して回避することができます。
下図のように Jira 課題管理画面 > 解決状況 のページから翻訳を設定し、重複して表示されてしまう項目に対して識別できる表示となるように名前を付けてください。
解決状況自体の名前が変更されているわけではないので、プロジェクト作成時に解決状況が新しく作成されることもなくなり、重複して表示される問題も解消します。
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